Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter
Powered by Vanilla. Made with Bootstrap.
Theme built by Kasper Kronborg Isager
500 HTTP (Internal Server Error)
  • hey there, i have the weirdest problam.
    there is this site i am working on for some time, and all of a sudden it does not load!! not the index page and not the cms.
    on chrome and explorer i get a 500 HTTP (Internal Server Error) and on firefox a blank page.
    i have checked the error _log and it has this line in it :
    [29-Mar-2013 01:47:04 Europe/Moscow] PHP Fatal error: Call to undefined function mb_internal_encoding() in /home/fbstorag/public_html/adiamar.co.il/cms/library/includes/general.include.php on line 32-29]
    Needless to say, i havent changed nothing on the website, and other sites i have been working on with feindura work just fine.
    by the way. i do not live in Europe/Moscow if that has anything to do with that.
    please help :((
  • hi,

    if you check here
    http://php.net/manual/de/function.mb-internal-encoding.php
    then you see that this function is only available since PHP 4.0.6, so the only guess i have is that your PHP version dropped somehow.

    feindura needs at least PHP 5.1..

    thats the only guess i have.
  • thanks for the quick replay.
    ok, tested it and it says : PHP Version 5.3.23
    whats next ?
  • hi,

    i found this:


    mbstring is a "non-default" extension, that is not enabled by default ; see this page of the manual :

    Installation

    mbstring is a non-default extension. This means it is not enabled by default. You must explicitly enable the module with the configure option. See the Install section for details

    So, you might have to enable that extension, modifying the php.ini file (and restarting Apache, so your modification is taken into account)


    Here you can find out how to activate it.
    http://www.php.net/manual/de/mbstring.installation.php

    But i guess you hoster changed something in its PHP settings and they have to do it.
  • hey, thanks. the problame was with the web hosting. moved to a new server and every thing is fixed
  • good to hear that!
  • I know it sounds crazy, but cookies might be an issue! I had the same problem.

    Changed the index.php with my template by one html tag and afterwards only 500 error in backend and frontend. (STRATO Hosting). I had a look at the includes.php and saw the cookie stuff.

    After deleting all domain cookies I could access the site again!

    Maybe this helps someone! ;)

    Best Sascha
  • but if you delete the cookie stuff, you shouldn't be able to log in the backend do you?
    in the frontend the cookier is used to store the session data. the session is then used to prevent double counting of users, when moving around pages.
  • I had to relogin of course. But at least there was no 500 error any longer.
  • hello.. going back to this subject.
    i started working with a new GO DADDY server. and get a 500 error when trying to access the cms (path/cms). *this is how i called the feindura folder.
    the only solution that works so far is deleting the .htaccess file.
    can it work without it? whats the risks? is there another solution?
    i cant get the editor display to look like the website (with the body.container method). is it related to the .htaccess file somehow?
    Regards,
    ofer ziv
  • hi,

    the .htaccess file in the cms folder is not necessary, it only regulates caching for the backend files.
    how this works for godaddy i dont know, but normally you should only set the website path right in the admin settings, also don't forget to set the right path for you css files in the html editor settings there