Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter
Powered by Vanilla. Made with Bootstrap.
Theme built by Kasper Kronborg Isager
pretty url's
  • hellow again.
    i cant get the pretty url's to work.
    you wrote something about 'apache server mod_rewrite' but i have no idea what it is.
    another thing is that you say to delete the .htaccess file. does it mean the one in the cms folder? cause i cant find another even after enabling "show hidden files" in filezilla.
  • hi,

    the pretty urls work only on a apache server, where you can use htaccess files and where the mod_rewrite module is installed.

    you should have an htaccess file in the cms folder (but maybe you deleted it?)

    for pretty urls you only need one in the root of your website ( "/" ). make sure you set the websites path right to "/" and then enable pretty urls, he then should create a .htaccess file in the root with the necessary rewrite rules.

    if it doesn't work it could be that you don't have write permissions in the root folder, or that the website path is set wrong.. ... or you dont have the mod_rewrite module installed. you can find that out by adding this to you index.php and check if it has the module in the list
    print_r(apache_get_modules());
  • this is what i got :

    Array ( [0] => core [1] => prefork [2] => http_core [3] => mod_so [4] => mod_macro [5] => mod_authn_file [6] => mod_authn_dbm [7] => mod_authn_anon [8] => mod_authn_dbd [9] => mod_authn_default [10] => mod_authz_host [11] => mod_authz_groupfile [12] => mod_authz_user [13] => mod_authz_dbm [14] => mod_authz_owner [15] => mod_authz_default [16] => mod_auth_basic [17] => mod_geoip [18] => mod_expires [19] => mod_include [20] => mod_filter [21] => mod_deflate [22] => mod_log_config [23] => mod_logio [24] => mod_env [25] => mod_mime_magic [26] => mod_cern_meta [27] => mod_setenvif [28] => mod_version [29] => mod_ssl [30] => mod_mime [31] => mod_status [32] => mod_autoindex [33] => mod_info [34] => mod_suexec [35] => mod_cgi [36] => mod_vhost_alias [37] => mod_negotiation [38] => mod_dir [39] => mod_imagemap [40] => mod_actions [41] => mod_speling [42] => mod_alias [43] => mod_rewrite [44] => mod_php5 )
  • number 43 says that you have mod rewrite, so it should work when you activate it.
    the only problem could be that it can't save the htaccess file, due to permission issues.

    i also see that you have php running as apache module, that can be the problem, to prevent permission problems its the best if you have PHP running as (Fast) CGI module. maybe you can change that in you server configuration?
  • ok.. after so many attempts i have no luck. the pretty url simply doesnt work for me.
    i have talked to the web hosting company and they say the apache server mod_rewrite is enable. tried to delete the htaccess, and nothing. after few more tries i almost worked but it seems that it didnt load the css at all.
    here is the link : http://rrlaw.co.il/eng/
    is it possible that i will give you access to the cms? i have a user ready with admin permissions. that would help me alot.

    my second problame with the pretty url is that there is no support for hebrew language. is that fixable?
    thanks for all..
  • hi,

    hebrew language :) iam not so familiar with non ascii letters and how to implement them in a url :) i guess you have to write them in english.

    the speaking url wrk fine, but you have to set the base path either manually or use the createMetaTags() method, which will set the right base path depending on the "website path" setting in the admin settings.

    in short:

    if you use the createMetaTags() method (which you should) then you have to set the "website path" to "/eng/".

    and if you want to set in manually add this to you head section.
    <base href="/eng/">

    Be aware that if you move your website, you have to change the "website path" in the settings, or change the manual set base path meta tag.

    hope that helps you.
  • Thanks, I will try it and let you how it worked out.
    As for Hebrew, I obviously can't write the menu titles in English. It's a utf-8 coding.
    Can you think of how to change the coding?
    Regards ,
    Ofer ziv
  • hi,

    sorry i din't implement another encoding than utf-8, i thought it will be enough.
    but i probably should do this in the future.

    for this case you can only manually set the encoding in the head, but the createMetaTags, will aso create the UTF-8 encoding meta tag, so i dont know how you could work around for now..
  • no... UTF-8 is the right encoding. but for some resone i cant see the hebrew. i dont see gibrish as well, just nothing..
  • ? hm

    try to add the createMetaTags method.
  • ok the <base href="/eng/"> works!!
    now all i need is a solution to view it in hebrew
  • it adds the utf-8 encoding to you website, so you should be able to view it in hebrew..
  • going back to this..
    i have the pretty url working, but since the page title names are in hebrew it does not recognize them.
    insted it shows "domainname.com//" where the name should be there's nothing.
    (all the sites i build naturaly have utf-8 encoding in them)
    any ideas?
  • i can be that he can't translate the hebrew page names automatically, so you have to set the page name manually in the "edit page" on the top.
  • sorry, didn't quite get that.
    are you talking about the page edit in the cms?
    each page have a title which is in hebrew, and you are correct, it cant read the hebrew charecters.
    how can i make it read the hebrew charecters so it shows the pretty url?
  • in the latest version of feindura, you should be able to edit the link url of your page.
  • oh.
    i've tried to use the latest version, but there was a bug. i couldnt find the NEW PAGE button to start the home page :(
    do you know about this?
  • did you created a user and forgot to set it as admin?
  • if i just use the update you relesed i see no change.
    where can i find the edit url for the page?
  • on the top of an page in the cms, next to 'Link to this page' th edit button
  • got it. thought it would be visible at all times, not only if pretty url was activated LOL
    but sadly, it does not exept the hebrew charecters (does not change anything).
    any way around that?
  • oh, yeah i forgot that.
    no it doesn't accept hebrew characters, because its a url title you have to use ASCII, means, find a way to describe the titles in ascii
  • so i have no way on doing that? :(
    by the way, tried changing the url name(in the demo version), but it does not change on the website.
  • i guess no.

    i checked the demo, works for me.. did your reload the website?
  • hey. it works well (only in english) but there is a strange bug :
    any time i edit the page the "Link to this page" goes back to the default and not the one i have set for it. and i have to set it again. this is a major problame since the end user will not know how to do this, or forget to set it every time he edits the pages content.
    any way to fix that?
  • thanks for the hint, i fixed it.

    sadly i don't have time to create a new release. so the only way is to update is to use the newest version from github:
    https://github.com/frozeman/feindura-flat-file-cms/archive/feindura2.0.zip

    but make sure that you delete the following folders before you overwrite your version (and make a backup before!)
    Delete:
    - addons
    - doc
    - pages
    - .gitignore
    - plugins (or at least copy plugins you add additionally from your old plugin folder)
  • thanks alot. i have a few questions..
    what if i dont have the addons & doc folders and cannot delete them? do i need to upload them anyway?
    i also dont have the .gitignore file so i cant delete it.
    is backing up through the system is enough?
  • ok, i think it worked out.
    i have a different question..
    how come that sometimes i get a ?session=... when clicking a menu item?
    (something like that : http://f2fstorage.com/888/category/888and-you/enviroment/?session=5a73tbvabc541c9psd8mjgam02)
    is there a way around it?
  • The first questions. No you don't need those folders. And you should backup by copying you whole website inclusive the cms folder. The feindura backup. Only backups your pages and settings.

    The second. The session is used the first time you click a link. Then it stores it In a cookie so you dont need the session parameter anymore. Without that session it would count users twice. So yes it's needed right now.


    :)
  • thanks for your answer.
    and what if i dont need it to count users? the session is a bit of a problam for me with SEO
  • currently there is no option to remove this first session parameter, which gets generated.
  • if you seriously want to deactivate this feature, you can uncomment line 849 in the library/classes/feindura.class.php
  • can you tell me which file/s controls the pretty url charecter language?
    i want to try and make it work in heberw..
  • /library/classes/GerneralFunctions.class.php in the createHref method from line 2192 on