Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter
Powered by Vanilla. Made with Bootstrap.
Theme built by Kasper Kronborg Isager
a tag disappears on html mode
  • ok, i have the weirdst problam.
    i have these .a tags :
    <a class="button orange large" style="padding:20px 20px" href="javascript:emailCurrentPage()" target="_self"><i class="icon-email" style="font-size:2em;padding-left:2px;margin-top:4px;"></i></a>
    <a href="#" onclick="window.open('https://www.facebook.com/sharer/sharer.php?u='+encodeURIComponent(location.href),'facebook-share-dialog','width=626,height=436');return false;" class="button blue large" style="padding:20px 20px"><i class="icon-facebook" style="font-size:2em;padding-left:2px;margin-top:4px;"></i></a>
     
    <a href="#" onclick="window.print();return false;" class="button green large" style="padding:20px 20px"><i class="icon-mailinglists" style="font-size:2em;padding-left:2px;margin-top:4px;"></i></a>

    after saving its ok, but when i go back to the editor on html mode its gone.

    is there a way to solve this please?
  • go to adminsettings > html editor and remove the check on SafeHTML, then it should not remove thsi weird looking html.
  • hey, thank you.
    i see the X next to it but it is marked in grey and wont let me change it.
    any ideas?
  • you have to deactivate "Filter html", if this is already the case, i don't know, why its removing your HTML tags :(
  • im trying, but there is no option. the mark is greied out
    check out the print screen to see what i mean, link from dropbox :
    https://dl.dropboxusercontent.com/u/64322884/safe_html.jpeg
  • yeah i see, this means it doesnt filter the html, then i sadly don't know whats the cause. why he is deleting the html.

    could be that the CKEditor does this, because he thinks its map formatted html?
  • but as you can see the color is grey and i cant click on it like the other x (filter html, active style...)
  • sure, you dont need to active it, it has to be deactivated (which it is)...
    this means feindura is not filtering you html, so the problem lies in the HTML editor itself, which is the CKEditor.

    and im not sure what is causing this.

    can't you reduce the amount of javascript code in the html? i think this is what causes the problem.
  • ok, you are right!
    i found this : http://docs.ckeditor.com/#!/guide/dev_advanced_content_filter
    but i cant seem to find the file that i need to change.
    can you please give me a hand with that?
  • thanks that you took a look :)

    go to the file
    cms/library/javascripts/content.js
    and add after line 1430:
    CKEDITOR.config.allowedContent = true;


    this should fix it.
  • thank you so much for your help time after time after time. O:-)
    i have figured it out, and i dont think it has anything to do with the html filtering (or maybe it does).
    the problam was with the i tag for the icon-font and also because there there was nothing between the end and closing of the a tag. when i put   it did not delete it. also i needed to replace the i tag with span.
    but unfortunatly it also craped up the way it looked, so i had to replace to images insted.
  • no problem, glad that you could fix it.